spark-testing-base (homepage)

Base classes to use when writing tests with Spark

@holdenk / (8)

The spark-testing-base package makes it easy to test your Spark code. Starting with v0.0.5, this package is cross-compiled against different Spark versions (1.1.1, 1.2.0, 1.3.0). The version number is [spark-version]_[spark-testing-version]. So, for example, to include this for Spark version 1.2.0 use a version number of 1.2.0_0.0.5.


Tags

  • 3|testing
  • 1|streaming
  • 1|tools

How to

Include this package in your Spark Applications using:

spark-shell, pyspark, or spark-submit

> $SPARK_HOME/bin/spark-shell --packages com.holdenkarau:spark-testing-base_2.10:1.5.2_0.3.3

sbt

If you use the sbt-spark-package plugin, in your sbt build file, add:

spDependencies += "holdenk/spark-testing-base:1.5.2_0.3.3"

Otherwise,

libraryDependencies += "com.holdenkarau" % "spark-testing-base_2.10" % "1.5.2_0.3.3"

Maven

In your pom.xml, add:
<dependencies>
  <!-- list of dependencies -->
  <dependency>
    <groupId>com.holdenkarau</groupId>
    <artifactId>spark-testing-base_2.10</artifactId>
    <version>1.5.2_0.3.3</version>
  </dependency>
</dependencies>

Releases

Version: 1.5.2_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.3.1_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.6.1_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.6.0_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.11

Version: 1.5.1_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.5.0_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.4.1_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.4.0_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 1.3.0_0.3.3 ( af4096 | zip | jar ) / Date: 2016-04-19 / License: Apache-2.0 / Scala version: 2.10

Version: 0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.6.1_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.6.0_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.4.0_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.5.2_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.5.1_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.5.0_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.4.1_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.3.1_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 1.3.0_0.3.2 ( 808c2a | zip | jar ) / Date: 2016-03-25 / License: Apache-2.0 / Scala version: 2.10

Version: 0.3.1 ( 276734 | zip | jar ) / Date: 2016-02-02 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 47% , 1.1.0 - 51% , 1.3.0 - 71% , 1.4.0 - 78% , 1.5.0 - 86%

Version: 1.5.2_0.3.1 ( 276734 | zip | jar ) / Date: 2016-02-02 / License: Apache-2.0 / Scala version: 2.11

Spark Scala/Java API compatibility: 1.2.0 - 57% , 1.3.0 - 81% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.5.1_0.3.1 ( 276734 | zip | jar ) / Date: 2016-02-02 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 54% , 1.3.0 - 81% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.5.0_0.3.1 ( 276734 | zip | jar ) / Date: 2016-02-02 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 54% , 1.3.0 - 81% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.3.1_0.3.1 ( 276734 | zip | jar ) / Date: 2016-02-02 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 53% , 1.1.0 - 61% , 1.3.0 - 100% , 1.4.0 - 98% , 1.5.0 - 86%

Version: 0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 39% , 1.1.0 - 43% , 1.3.0 - 75% , 1.4.0 - 81% , 1.5.0 - 88%

Version: 1.6.0_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 39% , 1.1.0 - 43% , 1.3.0 - 75% , 1.4.0 - 81% , 1.5.0 - 88%

Version: 1.5.2_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 41% , 1.1.0 - 45% , 1.3.0 - 83% , 1.4.0 - 92% , 1.5.0 - 100%

Version: 1.5.1_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 41% , 1.1.0 - 45% , 1.3.0 - 83% , 1.4.0 - 92% , 1.5.0 - 100%

Version: 1.5.0_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 41% , 1.1.0 - 45% , 1.3.0 - 83% , 1.4.0 - 92% , 1.5.0 - 100%

Version: 1.4.1_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 42% , 1.1.0 - 46% , 1.3.0 - 88% , 1.4.0 - 100% , 1.5.0 - 91%

Version: 1.4.0_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 42% , 1.1.0 - 46% , 1.3.0 - 88% , 1.4.0 - 100% , 1.5.0 - 91%

Version: 1.3.1_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 44% , 1.1.0 - 51% , 1.3.0 - 100% , 1.4.0 - 98% , 1.5.0 - 88%

Version: 1.3.0_0.3.0 ( 8bbefc | zip | jar ) / Date: 2016-01-23 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 44% , 1.1.0 - 51% , 1.3.0 - 100% , 1.4.0 - 98% , 1.5.0 - 88%

Version: 1.5.1_0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-05 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 38% , 1.1.0 - 41% , 1.3.0 - 82% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.4.1_0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-05 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 39% , 1.1.0 - 43% , 1.3.0 - 87% , 1.4.0 - 100% , 1.5.0 - 90%

Version: 1.4.0_0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-05 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 39% , 1.1.0 - 43% , 1.3.0 - 87% , 1.4.0 - 100% , 1.5.0 - 90%

Version: 0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-04 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 38% , 1.1.0 - 41% , 1.3.0 - 82% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.5.0_0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-04 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 38% , 1.1.0 - 41% , 1.3.0 - 82% , 1.4.0 - 91% , 1.5.0 - 100%

Version: 1.3.0_0.2.1 ( 3ffb1f | zip | jar ) / Date: 2015-11-04 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 41% , 1.1.0 - 48% , 1.3.0 - 100% , 1.4.0 - 98% , 1.5.0 - 88%

Version: 1.3.0_0.2.0 ( fda2ac | zip | jar ) / Date: 2015-10-28 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 34% , 1.1.0 - 42% , 1.3.0 - 100% , 1.4.0 - 99% , 1.5.0 - 86%

Version: 1.5.1_0.2.0 ( cd33d2 | zip | jar ) / Date: 2015-10-27 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 31% , 1.1.0 - 38% , 1.3.0 - 82% , 1.4.0 - 93% , 1.5.0 - 100%

Version: 1.5.0_0.2.0 ( cd33d2 | zip | jar ) / Date: 2015-10-27 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 31% , 1.1.0 - 38% , 1.3.0 - 82% , 1.4.0 - 93% , 1.5.0 - 100%

Version: 1.4.1_0.2.0 ( cd33d2 | zip | jar ) / Date: 2015-10-27 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 32% , 1.1.0 - 39% , 1.3.0 - 85% , 1.4.0 - 100% , 1.5.0 - 87%

Version: 1.4.0_0.2.0 ( cd33d2 | zip | jar ) / Date: 2015-10-27 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 32% , 1.1.0 - 39% , 1.3.0 - 85% , 1.4.0 - 100% , 1.5.0 - 87%

Version: 0.1.3 ( bd17d9 | zip | jar ) / Date: 2015-10-07 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 35% , 1.1.0 - 45% , 1.3.0 - 80% , 1.4.0 - 95% , 1.5.0 - 100%

Version: 1.5.0_0.1.3 ( bd17d9 | zip | jar ) / Date: 2015-10-07 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 35% , 1.1.0 - 45% , 1.3.0 - 80% , 1.4.0 - 95% , 1.5.0 - 100%

Version: 1.4.1_0.1.3 ( bd17d9 | zip | jar ) / Date: 2015-10-07 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 36% , 1.1.0 - 46% , 1.3.0 - 83% , 1.4.0 - 100% , 1.5.0 - 81%

Version: 1.4.0_0.1.3 ( bd17d9 | zip | jar ) / Date: 2015-10-07 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 36% , 1.1.0 - 46% , 1.3.0 - 83% , 1.4.0 - 100% , 1.5.0 - 81%

Version: 0.1.1 ( e94fda | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 51% , 1.2.0 - 55% , 1.3.0 - 90% , 1.4.0 - 100%

Version: 1.4.1_0.1.1 ( e94fda | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 51% , 1.2.0 - 55% , 1.3.0 - 90% , 1.4.0 - 100%

Version: 1.4.0_0.1.1 ( e94fda | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 51% , 1.2.0 - 55% , 1.3.0 - 90% , 1.4.0 - 100%

Version: 1.3.0_0.1.1 ( e94fda | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 54% , 1.1.0 - 56% , 1.2.0 - 60% , 1.3.0 - 100% , 1.4.0 - 98%

Version: 1.4.0_0.1.0 ( 711d66 | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 51% , 1.2.0 - 55% , 1.3.0 - 90% , 1.4.0 - 100%

Version: 0.1.0 ( 0c3c47 | zip | jar ) / Date: 2015-08-18 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 50% , 1.1.0 - 51% , 1.2.0 - 55% , 1.3.0 - 90% , 1.4.0 - 100%

Version: 1.3.0_0.0.5 ( 43fcb2 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 53% , 1.1.0 - 54% , 1.2.0 - 57% , 1.3.0 - 100%

Version: 1.2.0_0.0.5 ( 29c36c | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 88% , 1.1.0 - 91% , 1.2.0 - 100% , 1.3.0 - 98%

Version: 1.1.1_0.0.5 ( bec125 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 96% , 1.1.0 - 100% , 1.2.0 - 99% , 1.3.0 - 98%

Version: 0.0.5 ( 24cf50 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 53% , 1.1.0 - 54% , 1.2.0 - 57% , 1.3.0 - 100%

Version: 0.0.4 ( b77e73 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 53% , 1.1.0 - 54% , 1.2.0 - 57% , 1.3.0 - 100%

Version: 0.0.3 ( 47bb73 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 96% , 1.1.0 - 100% , 1.2.0 - 99% , 1.3.0 - 98%

Version: 0.0.2 ( 47bb73 | zip | jar ) / Date: 2015-03-30 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 96% , 1.1.0 - 100% , 1.2.0 - 99% , 1.3.0 - 98%

Version: 0.0.1 ( 8dbdc5 | zip | jar ) / Date: 2015-02-07 / License: Apache-2.0