Binary compatibility report for the spark-cassandra-connector_2.10-1.4.1 library  between 1.4.0 and 1.4.0 versions   (relating to the portability of client application spark-cassandra-connector_2.10-1.4.1.jar)

Test Info


Library Namespark-cassandra-connector_2.10-1.4.1
Version #11.4.0
Version #21.4.0
Java Version1.7.0_85

Test Results


Total Java ARchives5
Total Methods / Classes1300 / 3563
VerdictCompatible

Problem Summary


SeverityCount
Added Methods-0
Removed MethodsHigh0
Problems with
Data Types
High0
Medium0
Low0
Problems with
Methods
High0
Medium0
Low0

Java ARchives (5)


spark-catalyst_2.10-1.4.0.jar
spark-core_2.10-1.4.0.jar
spark-hive_2.10-1.4.0.jar
spark-sql_2.10-1.4.0.jar
spark-streaming_2.10-1.4.0.jar

to the top




Generated on Wed Dec 9 13:02:30 2015 for spark-cassandra-connector_2.10-1.4.1 by Java API Compliance Checker 1.4.1  
A tool for checking backward compatibility of a Java library API