spark-avro (homepage)

Integration utilities for using Spark with Apache Avro data

@databricks / (11)

Integration utilities for using Spark with Apache Avro data


Tags

  • 6|sql
  • 4|input
  • 4|avro
  • 3|data source
  • 2|library
  • 2|tutorial

How to

Include this package in your Spark Applications using:

spark-shell, pyspark, or spark-submit

> $SPARK_HOME/bin/spark-shell --packages com.databricks:spark-avro_2.11:3.0.1

sbt

If you use the sbt-spark-package plugin, in your sbt build file, add:

spDependencies += "databricks/spark-avro:3.0.1"

Otherwise,

libraryDependencies += "com.databricks" % "spark-avro_2.11" % "3.0.1"

Maven

In your pom.xml, add:
<dependencies>
  <!-- list of dependencies -->
  <dependency>
    <groupId>com.databricks</groupId>
    <artifactId>spark-avro_2.11</artifactId>
    <version>3.0.1</version>
  </dependency>
</dependencies>

Releases

Version: 3.0.1-s_2.11 ( 5b01ac | zip | jar ) / Date: 2016-09-15 / License: Apache-2.0 / Scala version: 2.11

Version: 3.0.1-s_2.10 ( 5b01ac | zip | jar ) / Date: 2016-09-15 / License: Apache-2.0 / Scala version: 2.10

Version: 3.0.0-s_2.11 ( fa59a5 | zip | jar ) / Date: 2016-08-30 / License: Apache-2.0 / Scala version: 2.11

Version: 3.0.0-s_2.10 ( fa59a5 | zip | jar ) / Date: 2016-08-30 / License: Apache-2.0 / Scala version: 2.10

Version: 2.0.1-s_2.10 ( 4a0983 | zip | jar ) / Date: 2015-09-08 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 14% , 1.1.0 - 52% , 1.2.0 - 57% , 1.3.0 - 54% , 1.4.0 - 100%

Version: 1.0.0 ( c5612d | zip | jar ) / Date: 2015-04-10 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 11% , 1.1.0 - 37% , 1.2.0 - 43% , 1.3.0 - 100%

Version: 0.2.0 ( a788c9 | zip | jar ) / Date: 2015-04-10 / License: Apache-2.0 / Scala version: 2.10

Spark Scala/Java API compatibility: 1.0.0 - 40% , 1.1.0 - 48% , 1.2.0 - 100% , 1.3.0 - 12%

Version: 0.1 ( dcc88e | zip | jar ) / Date: 2014-11-27 / License: BSD 3-Clause